12 лет назад 31 октября 2006 в 15:04 203
Столкнулся с крайне неприятным глюком: в Windows XP перестали отображаться иконки в системном трее, или, как его сейчас называют, области уведомлений. Притом что в настройках программ, которые там обычно висели, все стоит по-прежнему, значок в трее включен. Та же история с сетевыми соединениями: флаг отображения статуса в трее включен, а значков нет. Все настройки перерыл, все проверил – не могу привести все в нормальный вид. Помогайте!

одобные симптомы, а также глюки типа “зависающего” таск-бара или кнопки “Пуск”, которая начинает работать только через пару минут после включения ПК, могут быть признаками того, что у вас запущена служба Simple Service Discovery Protocol (SSDP). Попробуйте отключить ее в настройках служб. После этого перестанут автоматически определяться новые сетевые устройства, но и описанные вами сбои должны пропасть. В ряде случаев помогает обратное действие – требуется поставить службу и сервис Universal Plug and Play на автозапуск.Ну и, разумеется, не надо забывать о стандартном механизме скрытия значков: откройте свойства “Панели задач” и снимите флаг Hide inactive icons. Кроме того, отключение автоматического входа в систему также может избавить вас от этого сбоя. Для этого введите в меню Run команду control userpasswords2. Появится диалоговое окно. Проверьте, установлен ли в нем флаг “Требовать ввод имени пользователя и пароля”.

Наконец, в некоторых ситуациях помогает использование специальной программы, которая умеет управлять порядком и временем автозагрузки программ при старте операционной системы. Называется эта утилита Tech-Pro Utilities Startup, и скачать вы ее можете по адресу www.tech-pro.net/startup.html. Вообще, проблема эта довольно актуальна, и писем с описаниями подобных сбоев приходит немало. Поэтому, если кому-то из вас, уважаемые читатели, известны другие способы решения проблемы, связанной с исчезновением иконок из трея, очень просим поделиться с нами своим опытом, а уж мы постараемся, чтобы ваши советы стали доступны широкой общественности.

Никто не прокомментировал материал. Есть мысли?

Есть более радикальный метод – переустановка системы, но везде есть свои минусы, например операционная система должна соответствовать установленному оборудованию, и другие… 😉

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\upnphost]
“Start”=dword:00000004

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SSDPSRV]
“Start”=dword:00000004

И будет вам счастье

Nic, спасибо – очень помогли ваши 2 строчки в реестре. У меня после установки Avira на WinXP SP3 из трея пропала половина значков. Помогал токо перезапуск explorer.exe. Но после рестарта – опять все пропадало. А теперь – OK!

присоединяюсь к посту, правка в реестре помогла, значки грузятся нармуль. Спасибо!

Спасибо, добрый человек, совет помог. Проблема появилась после установки кучи новых системных обновлений.
Значок громкости появился, но перестал “пумкать” когда выставляешь уровень громкости. Пойду искать может что-то с системными звуками.
Еще раз спасибо за четкое решение.

Спасибо, Nik! Рецепт помог.
Только иконка Касперского почему-то не вернулась, хотя в Диспетчере процесс виден. Как до него теперь достучаться — непонятно. Простой повторный запуск через Пуск не помогает.

to Анаит: надо скопировать волшебные строки из поста Nik-a; открыть Блокнот; вставить в чистый файл эти строки; сохранить файл с любым именем и расширением “.reg”, например, “IconsForewer.reg”; Блокнот закрыть; запустить созданный файл; подтвердить системе желание добавить информацию в реестр и перезапустить систему.

to Сергей: вы тоже не с рождения знали, как работать с системным реестром.