12 лет назад 31 октября 2006 в 15:30 65
Пишу в адрес Upgrade впервые, хотя уже давно являюсь постоянным читателем журнала. Обычно мне удавалось находить ответы на вопросы либо на страницах журнала, либо на различных форумах в интернете и решать возникающие вопросы. Но вот уже давно мучает меня одна проблема, решение которой никак не могу найти, несмотря на то что обращался на самые известные компьютерные форумы. Суть ее заключается в следующем.
Некоторые сайты не загружаются, при указании правильного (!) адреса открывается окно "The page cannot be displayed", то есть стандартное окно, которое обычно появляется, если адрес прописан неправильно.
Но стоит в адресной строке браузера ввести три буквы – www (а для некоторых сайтов, наоборот, убрать их!), как все начинает чудненько загружаться. Есть, правда, мизерное количество сайтов, в отношении которых этот "трюк" с www бесполезен.
Теперь о системе. На одной и той же машине (MB P4T533-C, CPU – 1,8 ГГц, ОЗУ- 1 Гбайт) стоят две системы, обе – Windows XP SP2 (русская и английская), ранее, до выхода SP2, был установлен SP1, но результат был тот же самый.
В русской системе все работает нормально, то есть все сайты загружаются, в английской же происходит глюк, описанный выше.
Причем ситуация не зависит от браузера (Maxthon, IE, Opera, Mozilla Firefox), от состояния прокси (включен-выключен), от состояния файрволла (Outpost, включен-выключен), от вида соединения и, естественно, от модема (ADSL либо dial-up).
Пробовал чистить кэш (в IE5), проверял систему на наличие spyware, троянов и прочей гадости с помощью Ad-aware и Dr. Web. Базы Ad-aware и Dr. Web обновляются регулярно. Проверял в реестре наличие префикса "http://" в папках URL
DefaultPrefix и URLPrefixes (ветвь HKLMSOFTWAREMicrosoftWindowsCurrentVersionURL).
Ничто не помогает.
Похожая картина наблюдалась у меня еще раньше (года 1,5 тому назад), но тогда мне удалось найти причину – виной глюкам была работа так называемого HOSTS file manager FastNet99 – DNS-ускорителя. После его отключения все стало загружаться. Сейчас он у меня отключен (не загружен).

умаю, причина сбоя в работе DNS. Поищите для начала на диске файл HOSTS (без расширения) и временно удалите его. Далее проверьте настройки интернет-соединения – возможно, там не указаны или указаны неверно DNS-серверы.

DNSДалее очистите кэш DNS – для этого используйте команду ipconfig /flushdns.
Проверьте также, присутствует ли в разделе системного реестра HKEY_LOCAL_MACHINESOFTWARE
MicrosoftWindowsCurrentVersionURLPrefixes параметр (типа REG_SZ): www=http://.

Никто не прокомментировал материал. Есть мысли?