11 лет назад 13 октября 2009 в 17:38 274

Ситуация следующая: имеется небольшая домашняя сетка – ADSL-роутер ASUS WL-AM604g с точкой доступа Wi-Fi, к которому подключены сетевое хранилище данных i-Stor iS607 и стационарный комп (есть еще ноут, но сейчас речь не о нем). На десктопе (мать MSI 790FX-GD70, процессор AMD Phenom II X3 720, четыре модуля оперативной памяти DIMM DDR3 1 Гбайт Patriot, видео MSI GTX 285 (1 Гбайт)) установлена Windows Vista Ultimate x64.

Непонятно, с чего на этой машине вдруг поломалось сетевое соединение, но как-то очень странно: не работает почта, клиент BitTorrent, на сайты тоже невозможно зайти, но при этом в сетевом окружении машина видит хранилище i-Stor. Я сначала подумал, что пропала связь с провайдером, однако на ноутбуке, подключенном по Wi-Fi, интернет прекрасно работает. Зашел с него в веб-панель управления роутером – там вроде все нормально. В общем не знаю, что и думать.

Наиболее вероятной причиной произошедшего мне видится повреждение интерфейса Windows Sockets. Чтобы проверить это, запустите командную строку и пропингуйте какой-нибудь хост – если вы получите сообщение об ошибке с кодом 10107, то все так и есть. Тогда выполните команду (с правами администратора) netsh winsock reset, а потом перегрузите ПК – должно помочь. Подробнее об этом читайте здесь: support.microsoft.com/kb/811259. Также настоятельно рекомендую вам проверить свой компьютер на вирусы, лучше всего с какого-нибудь LiveCD. Дело в том, что похожие сбои могут вызывать некоторые зловреды.

Никто не прокомментировал материал. Есть мысли?