10 лет назад 25 апреля 2009 в 3:27 40
Подключился я к местной локалке с полгода назад. Все было отлично. Затем за ненадобностью интернет оплачивать перестал. Пару недель назад вновь проплатил, но с коннектом возникли трудности. При включении компьютера (еще до того, как я запускаю заведомо правильно настроенное соединение), после приветствия Windows, выскакивает такое сообщение: “Подключение ограничено или отсутствует” (из-за того, что компьютеру не был назначен сетевой адрес).

Я принял следующие меры по устранению неполадки.<BR>1. Сходил к провайдеру. Мне поменяли IP-адрес. Я уговорил ребят, которые там работают, сходить со мной. Покопавшись в настройках, сказали, что все о’кей. Подключили свой ноутбук – все отлично работает. Тут я призадумался. Дело в том, что Windows у меня стояла к тому времени без переустановок больше двух лет (пользуюсь Ashampoo Uninstaller). Ну, думаю, видимо, из-за этого.<BR>2. Снес Windows. Поставил с другого дистрибутива. Безрезультатно. То же самое сообщение.<BR>3. Купил и поочередно ставил две сетевые карты (Acorp и D-Link) в дополнение к интегрированному сетевому контроллеру 3Com (ставил в разные слоты). Никаких подвижек.<BR>Вопросы: почему же ничто не помогает и как с этим всем бороться?<BR>

Я бы на вашем месте попросил ребят из техподдержки провайдера переткнуть ваш кабель на другой порт коммутатора. Плюс совершенно безумная и труднореализуемая идея – взять короткий патчкорд и подключить его прямо к свитчу, перетащив комп туда, где он (свитч) стоит. Возможно, виноват кабель или какие-то наводки. Если все станет нормально, то будет ясно, где копать.

Потом я бы протестировал ОС другого типа, например Knoppix. Попробовал бы отключить в ПК всю периферию (насколько это возможно, конечно), вынув лишние устройства из слотов и отключив все в CMOS Setup. Или проблема в том, что не справляется блок питания либо какое-то оборудование готовится выйти из строя. Проверил бы питание: возможно, глюк как-то связан с заземлением, имеется разность потенциалов между вашим ПК и свитчем, которая не дает сети нормально работать. Попытался бы на несколько часов обесточить ПК: иногда помогает. Наконец, заменил бы материнскую плату: в конце концов, сетевухи вы меняли, а улучшений не происходило.

Как видите, ситуация сложная и запутанная. Причем источником проблем может оказаться именно то, на что никто никогда и не подумал бы. Те же неверные настройки (ничего не твикали? сервисы не отключали? DHCP включен? команда ipconfig -all что показывает? а ping? а route print? скорости в настройках сетевой карты менять пробовали? полудуплекс ставить?), засбоивший файрволл или тормознутость админов. Или кто-то из пользователей локалки просто сделал пиратское подключение с вашим IP- или MAC-адресом.

Никто не прокомментировал материал. Есть мысли?